2012-01-15 06:16:50Enforced log-in and error message
BaerbelW

baerbel-for-350@email...
93.231.165.19

I had thought that it was just a glitch with the Safari-browser on the iPad (where I've been having this issue for a couple of days now), but just now I had the same thing happening while using my Windows-laptop and Firefox:

All of a sudden, I had to sign-in to see the forum. Once I logged back in, the following message was displayed at the top of the page:

"Warning: Cannot modify header information - headers already sent by (output started at /home/7-web/74/95/skepticalscience.com/public/www/forumhead.php:158) in /home/7-web/74/95/skepticalscience.com/public/www/stoof/session.php on line 123"

Are others getting this weird behavious as well?

2012-01-15 09:24:10
Glenn Tamblyn

glenn@thefoodgallery.com...
124.180.194.63

Yes Baerbel. When login has been enforced after an absence, if I go back to a page that I have had open and refresh, after I have logged in I get that. refresh doesn't remove it. Clicking on Forum Home and starting again does.

 

Must be something to do with how JC's code for Login is handling some data for a page that has already been sent prior to the login.

2012-01-15 18:26:45
BaerbelW

baerbel-for-350@email...
93.231.151.156

Thanks, Glenn.

The weird thing yesterday on my laptop was, that I had been active on the forum throughout the day and then all of a sudden, when re-selecting a thread I had been reading earlier, the login was required.

On my iPad, though, I now have to re-login each time after a couple of hours of inactivity (eg. when I check the forums during my breakfast and lunch breaks at work).